Помощь - Поиск - Пользователи - Календарь
Полная версия этой страницы: Праблемы По Оси Z Во Время Фрезеровки
Все о станках с ЧПУ > Станки с ЧПУ, Hobby CNC > Обсуждение станков,устройств, вопросы
garryk
Господа помогите пожалуйста.
Во время фрезеровки 3D изделия, происходит сбой по оси Z, такое впечатление что по какойто причине происходит пропуск шагов. Причем пропуск может происходить как в + так и в -. И необязательно в 3-х координатах, может сбиться и в 2-х. Этот сбой происходит с характерным стуком в ШД.
При этом скорости обработки не большие 2000 мм/мин. Джампера на степе выставленны на 1000 импульсов на оборот. При таких настройках линейное перемещение на один шаг, учитывая все коэффициенты, получается приблизительно 0.05 мм. Коэфициент передачи 7. Программа управления NCStudio.
Если кто знает помогите пожалуйста.
CINN
А ускорения/замедления какие?
garryk
Цитата(CINN @ 19.9.2011, 19:31) *
А ускорения/замедления какие?

Я извиняюсь, я не силен в этих вопросах поэтому и обратился к профессионалам.
Я использую, как уже упоминал NCStudio. Параметры ускорения и замедления находятся в настройках этой программы?
Т.е. мне нужно найти где настраиваются эти параметры и попробовать "поиграть" с ними. Так?
еще раз извиняюсь за некомпетентность
CINN
Цитата(garryk @ 19.9.2011, 21:54) *
Я использую, как уже упоминал NCStudio. Параметры ускорения и замедления находятся в настройках этой программы?
Т.е. мне нужно найти где настраиваются эти параметры и попробовать "поиграть" с ними. Так?

Да, попробовать разные настройки.
Характеристика разгона/торможения ШД это, очень отдалённо, как трогание автомобиля с места- можно медленно, а можно "газ в пол", тогда уже и визг резины, и дым из-под колёс.
Вам нужно настроить эти характеристики так, чтобы мотор разгонялся/тормозил уверенно, но не "газ в пол".
garryk
Цитата(CINN @ 19.9.2011, 20:46) *
Да, попробовать разные настройки.
Характеристика разгона/торможения ШД это, очень отдалённо, как трогание автомобиля с места- можно медленно, а можно "газ в пол", тогда уже и визг резины, и дым из-под колёс.
Вам нужно настроить эти характеристики так, чтобы мотор разгонялся/тормозил уверенно, но не "газ в пол".

Спасибо. Попробую настройками ускарения и замедления поиграть.
А могут быть еще какиенибудь причины такого поведения ШД? На что мне нужно еще обратить внимание?
Может еще какие нибудь настройки покрутить?
garryk
А как вообще подбираются параметры ускорения и замедления, из каких соображений?
PKM
Цитата(garryk @ 19.9.2011, 20:51) *
А как вообще подбираются параметры ускорения и замедления, из каких соображений?

Из соображений мощности двигателя. Допустим, при максимальном моменте двигателя усилие привода 500Н. Тогда при массе подвижной части (ползуна, портала, каретки) 25 кг теоретически максимальное ускорение 20 м/с2. Конечно, нужно делать поправку на ШД, у которых момент резко падает на высоких оборотах. К сожалению, переменную величину ускорения в зависимости от скорости программы пока не поддерживают, по крайней мере, я таких не встречал.
garryk
Цитата(PKM @ 19.9.2011, 23:11) *
Из соображений мощности двигателя. Допустим, при максимальном моменте двигателя усилие привода 500Н. Тогда при массе подвижной части (ползуна, портала, каретки) 25 кг теоретически максимальное ускорение 20 м/с2. Конечно, нужно делать поправку на ШД, у которых момент резко падает на высоких оборотах. К сожалению, переменную величину ускорения в зависимости от скорости программы пока не поддерживают, по крайней мере, я таких не встречал.

Мне тут посоветовали еще питание на входе степ драйверов проверит, а конкретно той оси по которой сбой происходит, говорят что возможно причина в этом.
Как Вы считаете может быть в этом праблема.
CINN
Цитата(garryk @ 20.9.2011, 21:53) *
Мне тут посоветовали еще питание на входе степ драйверов проверит, а конкретно той оси по которой сбой происходит, говорят что возможно причина в этом.
Как Вы считаете может быть в этом праблема.

Проверка питания, соединений/контактов, целостности проводов- само собой, это делается с самого начала.
Поэтому люди это даже не советуют, полагая что итак уже всё проверено.
garryk
Цитата(CINN @ 20.9.2011, 21:04) *
Проверка питания, соединений/контактов, целостности проводов- само собой, это делается с самого начала.
Поэтому люди это даже не советуют, полагая что итак уже всё проверено.

И скажите еще пожалуста, какие на Ваш взглят еще могут быть причины помимо ускорения.

Я интересуюсь потом, что только на выходных мне представится возможность повозиться со станком, и до этого момента хотелось бы максисмум информации где искать.
CINN
Цитата(garryk @ 20.9.2011, 23:36) *
И скажите еще пожалуста, какие на Ваш взглят еще могут быть причины помимо ускорения.

Я интересуюсь потом, что только на выходных мне представится возможность повозиться со станком, и до этого момента хотелось бы максисмум информации где искать.

1.Соответствует ли потребностям моторов и аппаратуры характеристики блока(блоков) питания? Т.е. выдают ли нужные вольты и амперы?
2.Нет ли где обрывов/переломов жил проводов?
3.правильно ли и надёжно "контачат" клеммы/разъёмы?
4.Все ли сигнальные провода убраны в/имеют экранирующую оплётку?
5.Всё ли экранирование и заземление цело и подключено на "землю"?

Если с аппаратной частью всё в порядке- можно переходить к механике:
1.Проверить состояние направляющих и винтов(зубчатых реек)- нет ли существенного износа?
2.Проверить с использованием стрелочного индикатора зазоры в гайках(шестернях) приводов.
3.Проверить крепления вала винта к ШД- не ослабло ли?
4.Нет ли перекосов в геометрии приводов?

Если и тут всё в норме- "копать" управляющее ПО.
Ускорения/торможения, макс. и мин. скорости перемещений.
Попробовать дать выполнить станку программу с включённым шпинделем и ту же самую- с выключенным. Бывает работа плохо экранированного шпинделя влияет на пропуск шагов.
В этом случае, конечно, ничего не фрезеровать, а просто "водить" инструментом в воздухе. Пропущенные шаги можно выявить стрелочным индикатором, установленным жёстко на станок и "обнулённым" в начале работы. Если пропуски будут, то прои команде вернуться в ноль(там, где индикатор) индикатор покажет значение, отличное от нуля.
garryk
Цитата(CINN @ 20.9.2011, 22:54) *
1.Соответствует ли потребностям моторов и аппаратуры характеристики блока(блоков) питания? Т.е. выдают ли нужные вольты и амперы?
2.Нет ли где обрывов/переломов жил проводов?
3.правильно ли и надёжно "контачат" клеммы/разъёмы?
4.Все ли сигнальные провода убраны в/имеют экранирующую оплётку?
5.Всё ли экранирование и заземление цело и подключено на "землю"?

Если с аппаратной частью всё в порядке- можно переходить к механике:
1.Проверить состояние направляющих и винтов(зубчатых реек)- нет ли существенного износа?
2.Проверить с использованием стрелочного индикатора зазоры в гайках(шестернях) приводов.
3.Проверить крепления вала винта к ШД- не ослабло ли?
4.Нет ли перекосов в геометрии приводов?

Если и тут всё в норме- "копать" управляющее ПО.
Ускорения/торможения, макс. и мин. скорости перемещений.
Попробовать дать выполнить станку программу с включённым шпинделем и ту же самую- с выключенным. Бывает работа плохо экранированного шпинделя влияет на пропуск шагов.
В этом случае, конечно, ничего не фрезеровать, а просто "водить" инструментом в воздухе. Пропущенные шаги можно выявить стрелочным индикатором, установленным жёстко на станок и "обнулённым" в начале работы. Если пропуски будут, то прои команде вернуться в ноль(там, где индикатор) индикатор покажет значение, отличное от нуля.


Большое спасибо CINN на выходных попробую, потом отпишу.
Unikus
Цитата(garryk @ 19.9.2011, 18:51) *
А как вообще подбираются параметры ускорения и замедления, из каких соображений?

Также из соображения массы тела,которое нужно сдвинуть.Потому как есть такое понятие как инерция.Нужно её плавно разогнать,и также плавно затормозить.Соответственно,чем меньше масса тем выше значения ускорения и торможения.
garryk
Цитата(CINN @ 20.9.2011, 22:54) *
1.Соответствует ли потребностям моторов и аппаратуры характеристики блока(блоков) питания? Т.е. выдают ли нужные вольты и амперы?
2.Нет ли где обрывов/переломов жил проводов?
3.правильно ли и надёжно "контачат" клеммы/разъёмы?
4.Все ли сигнальные провода убраны в/имеют экранирующую оплётку?
5.Всё ли экранирование и заземление цело и подключено на "землю"?

Если с аппаратной частью всё в порядке- можно переходить к механике:
1.Проверить состояние направляющих и винтов(зубчатых реек)- нет ли существенного износа?
2.Проверить с использованием стрелочного индикатора зазоры в гайках(шестернях) приводов.
3.Проверить крепления вала винта к ШД- не ослабло ли?
4.Нет ли перекосов в геометрии приводов?

Если и тут всё в норме- "копать" управляющее ПО.
Ускорения/торможения, макс. и мин. скорости перемещений.
Попробовать дать выполнить станку программу с включённым шпинделем и ту же самую- с выключенным. Бывает работа плохо экранированного шпинделя влияет на пропуск шагов.
В этом случае, конечно, ничего не фрезеровать, а просто "водить" инструментом в воздухе. Пропущенные шаги можно выявить стрелочным индикатором, установленным жёстко на станок и "обнулённым" в начале работы. Если пропуски будут, то прои команде вернуться в ноль(там, где индикатор) индикатор покажет значение, отличное от нуля.


Доброго времени суток.

Вот чтоя сделал на выходных:
создал пробную программу в арткаме. обработка цилиндрической поверхности. стратегия - со смещением
1) проверил все по списку (за исключением проводов они у меня не экранированные, но я и шпиндель не включал, на всякий случай оплел кабель по Z проволокой и заземлил) - паблема не ушла
что делал дальше. без включения шпинделя. все замены делал с осью X
для лучшей наглядности снял мотор по Z и наблюдал за шестерней визуально и тактильно
2)поменял местами драйвера - праблема не ушла (думал может дело в драйвере)
3)поменял местами моторы - праблема не ушла (думал может дело в моторе)
4)поменял местами кабель на клемниках (думал дело в проводе)
5) поиграл ускорениями (только в минус и только ускорениями) станок стал ускоряться и замедляться медленнее- праблема не ушла ()
6) в программе заменил X на Z а Z на X решил посмотреть как себя поведет ось X в этом случае - то же самое

что мне стало покрайней мере ясно - 1) праблема в управляющих импульсах которые выдает плата управления - а)праблема либо в настройках NCstudio б)праблема в постпроцессоре - не правильно интерполирует по Z.

больше незнаю что и думать

что Вы по этому поводу думаете?
telavic
Цитата(CINN @ 20.9.2011, 21:54) *
1.Соответствует ли потребностям моторов и аппаратуры характеристики блока(блоков) питания? Т.е. выдают ли нужные вольты и амперы?
2.Нет ли где обрывов/переломов жил проводов?
3.правильно ли и надёжно "контачат" клеммы/разъёмы?
4.Все ли сигнальные провода убраны в/имеют экранирующую оплётку?
5.Всё ли экранирование и заземление цело и подключено на "землю"?

Если с аппаратной частью всё в порядке- можно переходить к механике:
1.Проверить состояние направляющих и винтов(зубчатых реек)- нет ли существенного износа?
2.Проверить с использованием стрелочного индикатора зазоры в гайках(шестернях) приводов.
3.Проверить крепления вала винта к ШД- не ослабло ли?
4.Нет ли перекосов в геометрии приводов?

Если и тут всё в норме- "копать" управляющее ПО.
Ускорения/торможения, макс. и мин. скорости перемещений.
Попробовать дать выполнить станку программу с включённым шпинделем и ту же самую- с выключенным. Бывает работа плохо экранированного шпинделя влияет на пропуск шагов.
В этом случае, конечно, ничего не фрезеровать, а просто "водить" инструментом в воздухе. Пропущенные шаги можно выявить стрелочным индикатором, установленным жёстко на станок и "обнулённым" в начале работы. Если пропуски будут, то прои команде вернуться в ноль(там, где индикатор) индикатор покажет значение, отличное от нуля.

Спасибо за исчерпывающий ответ, у меня тоже Z упал, буду теперь искать пошагово.
telavic
Цитата(garryk @ 26.9.2011, 20:35) *
Доброго времени суток.

Вот чтоя сделал на выходных:
создал пробную программу в арткаме. обработка цилиндрической поверхности. стратегия - со смещением
1) проверил все по списку (за исключением проводов они у меня не экранированные, но я и шпиндель не включал, на всякий случай оплел кабель по Z проволокой и заземлил) - паблема не ушла
что делал дальше. без включения шпинделя. все замены делал с осью X
для лучшей наглядности снял мотор по Z и наблюдал за шестерней визуально и тактильно
2)поменял местами драйвера - праблема не ушла (думал может дело в драйвере)
3)поменял местами моторы - праблема не ушла (думал может дело в моторе)
4)поменял местами кабель на клемниках (думал дело в проводе)
5) поиграл ускорениями (только в минус и только ускорениями) станок стал ускоряться и замедляться медленнее- праблема не ушла ()
6) в программе заменил X на Z а Z на X решил посмотреть как себя поведет ось X в этом случае - то же самое

что мне стало покрайней мере ясно - 1) праблема в управляющих импульсах которые выдает плата управления - а)праблема либо в настройках NCstudio б)праблема в постпроцессоре - не правильно интерполирует по Z.

больше незнаю что и думать

что Вы по этому поводу думаете?

Здравствуйте! Я смотрю, уже 4 года прошло, удалось вылечить Z? В чем была причина?
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.
Форум IP.Board © 2001-2020 IPS, Inc.